const regex = /\b(?:and|where)\s+Table\.Field(*SKIP)(*F)|Table\.Field/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:and|where)\\s+Table\\.Field(*SKIP)(*F)|Table\\.Field', 'gm')
const str = `Must match
Table.Field
something Table.Field
bTable.Field
Table.Field
bandTable.Field
Must not match
and Table.Field
where Table.Field
and Table.Field
where Table.Field`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}