re = /\b(?:and|where)\s+Table\.Field(*SKIP)(*F)|Table\.Field/m
str = 'Must match
Table.Field
something Table.Field
bTable.Field
Table.Field
bandTable.Field
Must not match
and Table.Field
where Table.Field
and Table.Field
where Table.Field'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end