use strict;
my $str = 'Must match
Table.Field
something Table.Field
bTable.Field
Table.Field
bandTable.Field
Must not match
and Table.Field
where Table.Field
and Table.Field
where Table.Field';
my $regex = qr/\b(?:and|where)\s+Table\.Field(*SKIP)(*F)|Table\.Field/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}