// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:and|where)\s+Table\.Field(*SKIP)(*F)|Table\.Field").unwrap();
let string = "Must match
Table.Field
something Table.Field
bTable.Field
Table.Field
bandTable.Field
Must not match
and Table.Field
where Table.Field
and Table.Field
where Table.Field";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}