using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])[^$1]+\1";
string input = @"We are looking for phrase within quotes and it can be multiline ""check we have a return here
but this line is still part of previouse one 'a' string"".
It breaks once we have another 'testing with single quotes ""suranding"" not literature';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}