$re = '/([\'"])[^$1]+\1/';
$str = 'We are looking for phrase within quotes and it can be multiline "check we have a return here
but this line is still part of previouse one \'a\' string".
It breaks once we have another \'testing with single quotes "suranding" not literature\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);