const regex = /(['"])[^$1]+\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'"])[^$1]+\\1', 'g')
const str = `We are looking for phrase within quotes and it can be multiline "check we have a return here
but this line is still part of previouse one 'a' string".
It breaks once we have another 'testing with single quotes "suranding" not literature';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}