re = /(['"])[^$1]+\1/
str = 'We are looking for phrase within quotes and it can be multiline "check we have a return here
but this line is still part of previouse one \'a\' string".
It breaks once we have another \'testing with single quotes "suranding" not literature\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end