import Foundation
let pattern = #"(['"])[^$1]+\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
We are looking for phrase within quotes and it can be multiline "check we have a return here
but this line is still part of previouse one 'a' string".
It breaks once we have another 'testing with single quotes "suranding" not literature';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)