using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]*)(?:\/|_.*?(?:\/|$))";
string input = @"""home/products/product_name_1/details/some_options""
""home/products/product_name_1/details/some_options""
""home/products/some_product_name_1/details_1/some_options""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}