$re = '/([a-zA-Z]*)(?:\/|_.*?(?:\/|$))/mi';
$str = '"home/products/product_name_1/details/some_options"
"home/products/product_name_1/details/some_options"
"home/products/some_product_name_1/details_1/some_options"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);