import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]*)(?:\\/|_.*?(?:\\/|$))";
final String string = "\"home/products/product_name_1/details/some_options\"\n"
+ "\"home/products/product_name_1/details/some_options\"\n"
+ "\"home/products/some_product_name_1/details_1/some_options\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}