import re
regex = re.compile(r"([a-zA-Z]*)(?:\/|_.*?(?:\/|$))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"home/products/product_name_1/details/some_options\"\n"
"\"home/products/product_name_1/details/some_options\"\n"
"\"home/products/some_product_name_1/details_1/some_options\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")