// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([a-zA-Z]*)(?:\/|_.*?(?:\/|$))").unwrap();
let string = "\"home/products/product_name_1/details/some_options\"
\"home/products/product_name_1/details/some_options\"
\"home/products/some_product_name_1/details_1/some_options\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}