#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^\n\/\\]+|\\[\\\/]?)+"
Local $sString = "aaaa/bbb\/ccc" & @CRLF & _
"this/is\/a/\/str\\/ing" & @CRLF & _
"aaaa/bbb\\/ccc/ddd\/eee/fff/ggg" & @CRLF & _
"aaaa/\bbb" & @CRLF & _
"this/is\/a/dumb/str\\/ing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")