import re
regex = re.compile(r"(?:[^\n\/\\]+|\\[\\\/]?)+", flags=re.MULTILINE)
test_str = ("aaaa/bbb\\/ccc\n"
"this/is\\/a/\\/str\\\\/ing\n"
"aaaa/bbb\\\\/ccc/ddd\\/eee/fff/ggg\n"
"aaaa/\\bbb\n"
"this/is\\/a/dumb/str\\\\/ing")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")