package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^\n\/\\]+|\\[\\\/]?)+`)
var str = `aaaa/bbb\/ccc
this/is\/a/\/str\\/ing
aaaa/bbb\\/ccc/ddd\/eee/fff/ggg
aaaa/\bbb
this/is\/a/dumb/str\\/ing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}