$re = '/(?:[^\n\/\\\\]+|\\\\[\\\\\/]?)+/m';
$str = 'aaaa/bbb\\/ccc
this/is\\/a/\\/str\\\\/ing
aaaa/bbb\\\\/ccc/ddd\\/eee/fff/ggg
aaaa/\\bbb
this/is\\/a/dumb/str\\\\/ing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);