using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^"".*?:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?).*?(-?\d+(?:\.\d+)?)";
string input = @"""Coordenadas: 0, 63, -5|hhhf♀""
""Coordenadas: 0, 63.5, -5.695|hhhf♀""
""Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀""
""Coordenadas: -8, 63, -5 \n♀""
""Coordenadas: 0, 63, -5""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}