re = /^".*?:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?).*?(-?\d+(?:\.\d+)?)/m
str = '"Coordenadas: 0, 63, -5|hhhf♀"
"Coordenadas: 0, 63.5, -5.695|hhhf♀"
"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀"
"Coordenadas: -8, 63, -5 \\n♀"
"Coordenadas: 0, 63, -5"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end