package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^".*?:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?).*?(-?\d+(?:\.\d+)?)`)
var str = `"Coordenadas: 0, 63, -5|hhhf♀"
"Coordenadas: 0, 63.5, -5.695|hhhf♀"
"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀"
"Coordenadas: -8, 63, -5 \n♀"
"Coordenadas: 0, 63, -5"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}