const regex = /^".*?:\s*(-?\d+(?:\.\d+)?),\D*?(-?\d+(?:\.\d+)?).*?(-?\d+(?:\.\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^".*?:\\s*(-?\\d+(?:\\.\\d+)?),\\D*?(-?\\d+(?:\\.\\d+)?).*?(-?\\d+(?:\\.\\d+)?)', 'gm')
const str = `"Coordenadas: 0, 63, -5|hhhf♀"
"Coordenadas: 0, 63.5, -5.695|hhhf♀"
"Coordenadas: 0, hhkjkm♀-63ss, -5|hhhf♀"
"Coordenadas: -8, 63, -5 \\n♀"
"Coordenadas: 0, 63, -5"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}