package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/example\.com\/[A-Z]+\/?$`)
var str = `http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/
^https?:\/\/example\.com\/[A-Z]+\/?$
or
^http:\/\/example\.com\/[A-Z]+\/?$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}