// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/example\.com\/[A-Z]+\/?$").unwrap();
let string = "http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/
^https?:\\/\\/example\\.com\\/[A-Z]+\\/?$
or
^http:\\/\\/example\\.com\\/[A-Z]+\\/?$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}