const regex = /^https?:\/\/example\.com\/[A-Z]+\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/example\\.com\\\/[A-Z]+\\\/?$', 'gm')
const str = `http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/
^https?:\\/\\/example\\.com\\/[A-Z]+\\/?\$
or
^http:\\/\\/example\\.com\\/[A-Z]+\\/?\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}