$re = '/^https?:\/\/example\.com\/[A-Z]+\/?$/m';
$str = 'http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/
^https?:\\/\\/example\\.com\\/[A-Z]+\\/?$
or
^http:\\/\\/example\\.com\\/[A-Z]+\\/?$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);