re = /^https?:\/\/example\.com\/[A-Z]+\/?$/m
str = 'http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/
^https?:\\/\\/example\\.com\\/[A-Z]+\\/?$
or
^http:\\/\\/example\\.com\\/[A-Z]+\\/?$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end