#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "~\([A-Z0-1]\)|[&|>=]\([A-Z0-1],[A-Z0-1]\)"
Local $sString = "&(&(=(A,B),>(&(A,B),~(C))),>(A,~(&(A,B))))" & @CRLF & _
"&(&(1,>(1,1)),>(A,~(1)))" & @CRLF & _
"&(&(1,1),>(A,1))" & @CRLF & _
"&(1,1)" & @CRLF & _
"" & @CRLF & _
"=(~(A),>(>(B,C),~(A)))" & @CRLF & _
"=(1,>(1,1))" & @CRLF & _
"=(1,1)" & @CRLF & _
"" & @CRLF & _
"(~(A))" & @CRLF & _
"(1)" & @CRLF & _
"" & @CRLF & _
">(A,B"
Local $sSubst = "1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)