$re = '/~\([A-Z0-1]\)|[&|>=]\([A-Z0-1],[A-Z0-1]\)/';
$str = '&(&(=(A,B),>(&(A,B),~(C))),>(A,~(&(A,B))))
&(&(1,>(1,1)),>(A,~(1)))
&(&(1,1),>(A,1))
&(1,1)
=(~(A),>(>(B,C),~(A)))
=(1,>(1,1))
=(1,1)
(~(A))
(1)
>(A,B';
$subst = "1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;