import Foundation
let pattern = #"~\([A-Z0-1]\)|[&|>=]\([A-Z0-1],[A-Z0-1]\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
&(&(=(A,B),>(&(A,B),~(C))),>(A,~(&(A,B))))
&(&(1,>(1,1)),>(A,~(1)))
&(&(1,1),>(A,1))
&(1,1)
=(~(A),>(>(B,C),~(A)))
=(1,>(1,1))
=(1,1)
(~(A))
(1)
>(A,B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)