// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"~\([A-Z0-1]\)|[&|>=]\([A-Z0-1],[A-Z0-1]\)").unwrap();
let string = "&(&(=(A,B),>(&(A,B),~(C))),>(A,~(&(A,B))))
&(&(1,>(1,1)),>(A,~(1)))
&(&(1,1),>(A,1))
&(1,1)
=(~(A),>(>(B,C),~(A)))
=(1,>(1,1))
=(1,1)
(~(A))
(1)
>(A,B";
let substitution = "1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}