package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`~\([A-Z0-1]\)|[&|>=]\([A-Z0-1],[A-Z0-1]\)`)
var str = `&(&(=(A,B),>(&(A,B),~(C))),>(A,~(&(A,B))))
&(&(1,>(1,1)),>(A,~(1)))
&(&(1,1),>(A,1))
&(1,1)
=(~(A),>(>(B,C),~(A)))
=(1,>(1,1))
=(1,1)
(~(A))
(1)
>(A,B`
var substitution = "1"
fmt.Println(re.ReplaceAllString(str, substitution))
}