const regex = /^(?>(25[0-5]|2[0-4]\d|1\d{2}|[1-9]\d|\d)\.){3}(?1)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>(25[0-5]|2[0-4]\\d|1\\d{2}|[1-9]\\d|\\d)\\.){3}(?1)$', 'gm')
const str = `100.109.237.255
0.0.0.0
0.0.249.232
4.123.0.255
172.16.255.255
23.123.234.234.4
04.234.234.
314..234.44.32
123.123.123.123.
255.255.255.255`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}