$re = '/^(?>(25[0-5]|2[0-4]\d|1\d{2}|[1-9]\d|\d)\.){3}(?1)$/m';
$str = '100.109.237.255
0.0.0.0
0.0.249.232
4.123.0.255
172.16.255.255
23.123.234.234.4
04.234.234.
314..234.44.32
123.123.123.123.
255.255.255.255';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);