# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(25[0-5]|2[0-4]\d|1\d{2}|[1-9]\d|\d)\.){3}(?1)$"
test_str = ("100.109.237.255\n"
"0.0.0.0\n"
"0.0.249.232\n"
"4.123.0.255\n"
"172.16.255.255\n"
"23.123.234.234.4\n"
"04.234.234.\n"
"314..234.44.32\n"
"123.123.123.123.\n"
"255.255.255.255")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.