use strict;
my $str = '100.109.237.255
0.0.0.0
0.0.249.232
4.123.0.255
172.16.255.255
23.123.234.234.4
04.234.234.
314..234.44.32
123.123.123.123.
255.255.255.255';
my $regex = qr/^(?>(25[0-5]|2[0-4]\d|1\d{2}|[1-9]\d|\d)\.){3}(?1)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}