import Foundation
let pattern = #"^(?>(25[0-5]|2[0-4]\d|1\d{2}|[1-9]\d|\d)\.){3}(?1)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
100.109.237.255
0.0.0.0
0.0.249.232
4.123.0.255
172.16.255.255
23.123.234.234.4
04.234.234.
314..234.44.32
123.123.123.123.
255.255.255.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)