using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d)(?!0(?![.]))(?:\d{0,3})(?:[.]\d{1,3})?$";
string input = @"111
111.11
11.1
1.1
11.111
0.1
1.1
1.233
0.111
001.1
1111
11.4444
1111.11
1111.1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}