$re = '/^(?=\d)(?!0(?![.]))(?:\d{0,3})(?:[.]\d{1,3})?$/m';
$str = '111
111.11
11.1
1.1
11.111
0.1
1.1
1.233
0.111
001.1
1111
11.4444
1111.11
1111.1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);