const regex = /^(?=\d)(?!0(?![.]))(?:\d{0,3})(?:[.]\d{1,3})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d)(?!0(?![.]))(?:\\d{0,3})(?:[.]\\d{1,3})?$', 'gm')
const str = `111
111.11
11.1
1.1
11.111
0.1
1.1
1.233
0.111
001.1
1111
11.4444
1111.11
1111.1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}