use strict;
my $str = '111
111.11
11.1
1.1
11.111
0.1
1.1
1.233
0.111
001.1
1111
11.4444
1111.11
1111.1111';
my $regex = qr/^(?=\d)(?!0(?![.]))(?:\d{0,3})(?:[.]\d{1,3})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}