#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?<scope>@[\d*a-z~-][\w*.~-]*)\/)?[\da-z~-][\w.~-]*$"
Local $sString = "mlly" & @CRLF & _
"@flex-development/mlly" & @CRLF & _
"@npm/thingy" & @CRLF & _
"crazy!" & @CRLF & _
".start-with-period" & @CRLF & _
"@npm-zors/money!time.js" & @CRLF & _
"@FLEX-DEVELOPMENT/MLLY" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")