const regex = /^(?:(?<scope>@[\d*a-z~-][\w*.~-]*)\/)?[\da-z~-][\w.~-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<scope>@[\\d*a-z~-][\\w*.~-]*)\\\/)?[\\da-z~-][\\w.~-]*$', 'gm')
const str = `mlly
@flex-development/mlly
@npm/thingy
crazy!
.start-with-period
@npm-zors/money!time.js
@FLEX-DEVELOPMENT/MLLY
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}