#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]*(\^[ABC][0-9]*)+|[0-9]+)$"
Local $sString = "43AA34C563B3545" & @CRLF & _
"43A34C563^BC3545" & @CRLF & _
"4334563^B3545" & @CRLF & _
"3345664345^CCC0" & @CRLF & _
"3345" & @CRLF & _
"" & @CRLF & _
"4334563^B4" & @CRLF & _
"^B^B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")