import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]*(\\^[ABC][0-9]*)+|[0-9]+)$";
final String string = "43AA34C563B3545\n"
+ "43A34C563^BC3545\n"
+ "4334563^B3545\n"
+ "3345664345^CCC0\n"
+ "3345\n\n"
+ "4334563^B4\n"
+ "^B^B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}