$re = '/^([0-9]*(\^[ABC][0-9]*)+|[0-9]+)$/m';
$str = '43AA34C563B3545
43A34C563^BC3545
4334563^B3545
3345664345^CCC0
3345
4334563^B4
^B^B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);