// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]*(\^[ABC][0-9]*)+|[0-9]+)$").unwrap();
let string = "43AA34C563B3545
43A34C563^BC3545
4334563^B3545
3345664345^CCC0
3345
4334563^B4
^B^B";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}