using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]*(\^[ABC][0-9]*)+|[0-9]+)$";
string input = @"43AA34C563B3545
43A34C563^BC3545
4334563^B3545
3345664345^CCC0
3345
4334563^B4
^B^B";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}