using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bkey="")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?="")";
string input = @"I found the key=""abcd-qwer-qaa-xyz-vwxc"" to salvation
I found the key=""abcd-qwer-qaa-xy-vwxc"" to salvation
I found the key=""abc-qwer-qaa-xyz-vwxc"" to salvation
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}