$re = '/(?<=\bkey=")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?=")/m';
$str = 'I found the key="abcd-qwer-qaa-xyz-vwxc" to salvation
I found the key="abcd-qwer-qaa-xy-vwxc" to salvation
I found the key="abc-qwer-qaa-xyz-vwxc" to salvation
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);